Archived | full text search
Skip navigation
3706 Views 5 Replies Latest reply: Jan 28, 2014 6:43 AM by kenhen93 RSS
Chris Riley Newbie 1 posts since
Jun 23, 2012
Currently Being Moderated

Nov 12, 2012 4:10 PM

Zenoss 4.2 anything but stable?



I'm really frustrated here. I have a large SolarWinds enviroment that I'd like to move to Zenoss. To put Zenoss through it's paces we moved a little over 100 devices consisting of network equipment and servers (physical, vmware and rhev). Despite a few UI bugs and odd behavior (like job completetion pop ups that never end) things were going really well. If this test was successful we would be moving to the Enterprise edition. However, after a restart of zenoss today we now receive the following message and no one can log in.


Type: <type 'exceptions.KeyError'>
Value: 1352753820

Traceback (most recent call last): File "/opt/zenoss/lib/python/ZPublisher/", line 126, in publish request, bind=1) File "/opt/zenoss/lib/python/ZPublisher/", line 77, in mapply if debug is not None: return debug(object,args,context) File "/opt/zenoss/lib/python/ZPublisher/", line 46, in call_object result=apply(object,args) # Type s<cr> to step into published object. File "/opt/zenoss/Products/ZenUtils/patches/", line 137, in login pas_instance.updateCredentials(request, response, login, password) File "/opt/zenoss/lib/python/Products/PluggableAuthService/", line 1100, in updateCredentials updater.updateCredentials(request, response, login, new_password) File "/opt/zenoss/lib/python/Products/PluggableAuthService/plugins/", line 102, in updateCredentials request.SESSION.set('__ac_name', login) File "/opt/zenoss/lib/python/ZPublisher/", line 1379, in __getattr__ v = self.get(key, default, returnTaints=returnTaints) File "/opt/zenoss/lib/python/ZPublisher/", line 1336, in get v = v() File "/opt/zenoss/lib/python/Products/Sessions/", line 101, in getSessionData return self._getSessionDataObject(key) File "/opt/zenoss/lib/python/Products/Sessions/", line 188, in _getSessionDataObject ob = container.new_or_existing(key) File "/opt/zenoss/lib/python/Products/Transience/", line 842, in new_or_existing self[key] = item File "/opt/zenoss/lib/python/Products/Transience/", line 454, in __setitem__ current_bucket = self._data[current_ts] KeyError: 1352753820

  • dpetzel Rank: Brown Belt 1,141 posts since
    Oct 17, 2010
    Currently Being Moderated
    1. Nov 12, 2012 10:23 PM (in response to Chris Riley)
    Re: Zenoss 4.2 anything but stable?

    Any recent zenpack installations that line up with the restart? If your really serious about enterprise, maybe contacting Zenoss sales, might get you some special attention on the issue


    The couple of other (unanswered) posts seem to be tied back to zenpack installations


    I did find one bug report in Jira about the posible of the time being wrong and/or changed. Was the time recently changed (or is it currently wrong) on this host?

  • hydruid Rank: Green Belt 262 posts since
    Nov 5, 2012
    Currently Being Moderated
    2. Nov 13, 2012 10:29 PM (in response to dpetzel)
    Re: Zenoss 4.2 anything but stable?

    It also wouldn't hurt to check a lot of the small things.


    Disk space, mysql passwords, and permissions

  • Ryan Matte ZenossMaster 653 posts since
    Mar 26, 2009
    Currently Being Moderated
    3. Nov 22, 2012 6:49 PM (in response to Chris Riley)
    Re: Zenoss 4.2 anything but stable?

    The last time I saw an error like this it was because there was a major change in the date/time on the server (it was moved in to the past).  Zope doesn't seem to like it when a date/time is active that it has already seen.  Also, just as a testament, I'm using Core 4 to monitor over 2100 devices and it's working fine.  It took a lot of tweaking/tuning to squeeze the performance out of it that I needed and I had to throw quite a bit of RAM at it (26GB), but it's working well.

  • Shane Scott ZenossMaster 1,373 posts since
    Jul 6, 2009
    Currently Being Moderated
    4. Nov 29, 2012 3:30 PM (in response to Ryan Matte)
    Re: Zenoss 4.2 anything but stable?



    On the zen master, su zenoss then zendmd.



    from Products.ZenUtils.Security import activateCookieBasedAuthentication












    Then exit zendmd and zopectl restart. Give it a try then.



    --Shane Scott (Hackman238)

  • kenhen93 Rank: White Belt 100 posts since
    Sep 27, 2011
    Currently Being Moderated
    5. Jan 28, 2014 6:43 AM (in response to Shane Scott)
    Re: Zenoss 4.2 anything but stable?

    Shane, This worked for me! Thank you!


    We just had to move our zenoss server from one rack to another which took around 1.5 hours in which it was down. When Zenoss finally came up, I had a keyerror that would not event let me login. This fixed it.

More Like This

  • Retrieving data ...


  • Correct Answers - 4 points
  • Helpful Answers - 2 points